↑ Top
Table of Contents

Visualisation (T26)

3D Visualisation

The Visualisation tool has been replaced by its predecessor 3D Explore, All aspects covered by this tool manual can be replicated in 3D Explore.See 3D Explore (T61) and Getting Started with 3D Explore (G23) for more information.

Visualisation Tool capabilities

The Visualisation tool enables you to visualise all INTREPID datasets. It includes the following customisable display features: You can:

  • Display single bands of grid datasets using:
  • Pseudocolour (based on ranges of values or a histogram)
  • Grey scale
  • Sun angle
  • Pseudocolour with sun angle drape
  • Contours.
  • Display ternary (3 band) grid datasets (usually radiometrics)
  • Display line datasets and show the values of a signal field using:
  • Pseudocolour
  • Profiles
  • Display point datasets and show the values of up to three signal fields, using:
  • Marker colour
  • Marker size
  • Marker angle
  • Marker text
  • Display polygon datasets, create new ones and turn label display on and off
  • Overlay a number of vector datasets on each other and on a grid dataset
  • Zoom and pan the display
  • View data values by clicking points on the display

Using the Visualisation tool

Launching the Visualisation tool from the Project Manager or command line

To use the Visualisation tool with the INTREPID graphic user interface
  1. Choose Visualisation Tool from the Display menu in Project Manager, or use the command visual.exe. INTREPID displays the Visualisation tool Main window.
  2. viswindo.png
  3. If you are about to display a large line or point dataset and want to speed up the data display on the screen, adjust the display subsampling rate for line or point datasets using the Display Subsampling option from the Line Display menu. (See Setting the display subsampling interval for details).
  4. If you have prepared settings for your display, load the corresponding task specification file using Open Taskfile or Load Options from the File menu. (See Specifying input and output files for detailed instructions.)
  5. If you do not want to load any further datasets, go to step 5.

  6. Specify the datasets for display. Use Load Line Dataset, Load Point Dataset, Load Poly Dataset, Load Grid Dataset and Load Ternary Grid from the File menu as required. (See Specifying input and output files for detailed instructions.)
  7. If you are displaying a point dataset INTREPID asks you to specify the signal fields for marker colour, size, angle and text. Click Cancel for the display attributes you do not want.

    If you are displaying a line dataset you can specify the signal field for pseudocolour and profile display using Load Signal Field for Line Dataset in the Line Display menu.

    You can load up to ten of each type of vector dataset (point, line, polygon).

    You can turn display on and off for each type of dataset.

    INTREPID displays the datasets in the Visualisation tool Main window.

  8. Examine and manipulate the display of the datasets according to your requirements as follows.
    • If you are viewing a grid dataset, switch between grey scale, pseudocolour, sun angle and sun angle drape displays. Change the parameters for these display formats as required using options from the Grid Display menu (See Grid dataset display (single band) for details).
    • If you are viewing a points dataset, turn colour and size Signal data display on and off as required. (See Point dataset display for details.)
    • If you are viewing a line dataset display a signal field using colour or stack profile (See Specifying input and output files for detailed instructions.
    • If you require a new polygon, trace it, specify a label and save it as a new polygon dataset if required (See Specifying input and output files for detailed instructions).
    • Zoom (enlarge an area of the display) and pan (examine different regions while enlarged) (See Zooming and panning the display for information).
    • Query points or distances in the dataset display. INTREPID will report information about the points in the Visualisation tool Main window (See Querying points for details)
  9. If you want to record specifications from this session as a task specification file, use Save Taskfile or Save Options from the File menu. (See Specifying input and output files for detailed instructions.)
  10. To exit from Visualisation tool, choose Quit from the File menu.

Notes:

  • You can control the effect of mouse operations in the dataset display area using the Mouse Mode options in the Command area of the Visualisation tool Main window. See Mouse mode summary for details.
  • To view the current display specifications choose Report from the Window menu. INTREPID displays the Visualisation tool Report window. See Displaying options for details and an example of a set of specifications.
  • You can view Help information by choosing options from the Help menu (See Help).

Associating datasets with the Visualisation tool in Windows

If you associate dataset files with the Visualisation tool in Windows, you can open them by double clicking in Windows Explorer or My Computer. See “Associating datasets with the Visualisation tool in Windows” in INTREPID installation guide (S05).

Specifying input and output files

You need to specify the datasets for viewing in the Visualisation tool. If you want to examine the signal data from a line or points dataset during the process, you must also specify the signal fields. If you trace a new polygon, you can save it as a polygon dataset.

INTREPID identifies the X, Y, line number and fiducial fields using dataset aliases. The dataset must have the following aliases, identifying appropriate fields.

Alias

Field

X

X coordinate (geographic location)

Y

Y coordinate (geographic location)

LineNumber

line number *

FID

fiducial sequence *

* These fields are optional. If you do not specify them, INTREPID will prompt you with an Open dialog box to specify them. If you do not specify them INTREPID will use a default system to create the missing numbers (See Line, fiducial and point numbers for details).

See “Vector dataset field aliases” in INTREPID database, file and data structures (R05) for more information about aliases.

Choose the options as required from the File menu. You can also save a traced polygon as a new polygon dataset, using the Polygon Display menu.

visualisation-tool00212.jpgviwmpoly.png

In each case INTREPID displays an Open or Save As dialog box. Use the directory and file selector to locate the file you require. (See “Specifying input and output files” in Introduction to INTREPID (R02) for information about specifying files).

INTREPID also often displays a field or band selection dialog box. Follow the instructions for the type of dataset you are loading.

viwbchlz.png

If you have already opened a vector dataset of similar type, INTREPID asks if you are replacing the existing dataset or adding another. See Displaying multiple vector datasets for detailed instructions.

Load Line Dataset Use this option to specify line datasets. INTREPID opens the dataset, locates the X and Y geographic coordinate fields using dataset aliases and display the lines in the Visualisation tool Main window.

Load Point Dataset Use this option to specify a point dataset. See Point dataset display for instructions.

Load Polygon Dataset Use this option to specify a polygon dataset. See Polygon dataset display for instructions.

Load Grid Dataset Use this option to specify a single band of a grid dataset. If you specify a multiband grid, INTREPID displays the Select Band dialog box. See Grid dataset display (single band) for instructions.

Load Ternary Grid Use this option to specify a multiband grid dataset. See Ternary Grid display for instructions.

Open Taskfile or Load Options If you want to use an existing task specification file to specify the display, use this option to specify the task specification file required. INTREPID will use the file to create the display. (See Displaying options for more information).

Save Taskfile or Save Options Use this option to save the current Visualisation tool display specifications as a task specification file. (See Displaying options for more information).

Load Signal field for Line Dataset (Line Display menu) Use this option to specify the signal field for both:

Save Traced Polygon (Polygon Display menu) Use this option to save a polygon you have just traced as a new polygon dataset. See Polygon dataset display for more information.

Displaying multiple vector datasets

If you have already specified one or more vector datasets of a certain type (point, line, polygon) and then go to load another, INTREPID asks you whether to add the new dataset to the display or replace the most recently loaded dataset. It displays the Add or Replace ... Dataset dialog box. This dialog box operates in the same way for line, point and polygon datasets. When you read this section you can substitute line, point or polygon for ‘...’ as required.

viwbadrp.png
  • To add the dataset, click Add another ... dataset.
  • To replace the previously loaded dataset, click Replace ... dataset last loaded.
  • You can also click Cancel loading the ... dataset.

The following picture shows a display with two line datasets.

viwwmuve.png

In the current version of the Visualisation tool:

  • You must specify signal fields and display characteristics for each vector dataset before you load the next dataset.
  • The signal field display controls only work for the most recently loaded dataset.
  • You can replace the most recently loaded dataset but you cannot unload a dataset.

Mouse mode summary

The Visualisation tool has three basic mouse operations, determined by the mouse mode options located at the bottom of the Main window Command area.

viwmmode.png
To select a mouse mode

Select the corresponding Mouse Mode option button.

Zoom or Trace Using this mode you can define rectangular regions for zooming the data display and trace new polygons. See Zooming and panning the display for details.

Query Using this mode you can click points and drag between pars of points to obtain information about the data they represent. See Querying points for details.

General display controls and options

While using the Visualisation tool with one or more datasets you can

Zooming and panning the display

You can enlarge and reduce the display (zoom in and out) and view different parts of it (pan).

To zoom in and out (enlarge/reduce) by steps

To zoom in (enlarge the display) choose Zoom In in the Command area of the Visualisation tool Main window. Each time you choose this button, INTREPID will enlarge the display by 25%.

To zoom out (reduce the display) choose Zoom Previous in the Command area of the Visualisation tool Main window. Each time you choose this button, INTREPID will return to the previous zoom level.

You can use these buttons at any time, no matter what mouse mode you have selected.

To zoom in on a selected area of the display

Select Zoom from the Mouse Mode options.

viwmmode00215.png

Hold down the left mouse button and drag diagonally (corner to corner) across the area that you want to enlarge. INTREPID will enlarge the selected region to fill the Data area of the window. If you choose Zoom Previous, having used this zooming in process, INTREPID will immediately zoom out to the full dataset display.

The illustration below is the a zoomed-in part of the grid dataset illustrated in section Grid dataset display (single band).

viwwfull.pngviwwzoom.png
To pan a zoomed-in display (view different parts)
viwczoom.png

The Pan/zoom indicator at the right of the Visualisation tool Main window in the centre consists of a small square within a larger square. The large square represents the whole display and the small square the part visible on the screen. When you drag the small square to a different part of the large square INTREPID shows the corresponding part of the display.

If you have zoomed out to view the whole display, the small square may occupy the whole of the large square and may therefore not be visible.

You can use the Pan/zoom indicator at any time, no matter what Mouse Mode you have selected.

Querying points

INTREPID can display information about

  • Individual points if you click them in your display or
  • Start and finish points if you mouse drag across a section of the display.

This section describes the information obtained while you are using Query mouse mode.

INTREPID displays information about the query points in the Status area. This is at the top of the Command area in the Visualisation tool Main window.

viwquere.png
To select Query mouse mode

Select Query from the Mouse Mode option buttons near the lower left corner of the Visualisation tool main window.

viwmmode00215.png
To view information about a point

Click it with the left mouse button and view the information in the Status area.

To view information about a pair of points

Drag from one point to the other using the left mouse button, then view the information in the Status area.

If INTREPID is displaying a grid without a line dataset, it displays information about the point on the grid that you click.

If INTREPID is displaying a line dataset, it displays information about the nearest point on a line to the click point.

How to read the status area

The following definitions, diagram and tables will help to explain the way that Visualisation tool reports information to you.

The click point is the position on the display which you click with the left mouse button.

The start point and finish point are the mouse button down and mouse button release points when you perform a left mouse button drag across part of the display.

If you consider a traverse line display as a set of line segments joining data points, the point on a line nearest to the click point is the point on a line segment nearest to the click point.

The following illustration shows a click point, data points and lines.

Notes:

  • Vector dataset data displayed comes from the most recently loaded vector dataset.
  • The names of datasets at the top of the status area asre the most recently loaded

The following table describes the information shown in the Status area during single click query operations.

Heading

Grid only

Line or Line + Grid

Point or Point + Grid

X, Y

X, Y coordinate of click point

X, Y coordinates of data point nearest to click point

X, Y coordinates of data point nearest to click point

Signal field

n/a

Loaded Signal field name

Colour Signal field name

Line

n/a

Line number of data point nearest to click point

Line dataset also present: Line number of data point nearest to click point

Line dataset not present: n/a

Fid

n/a

Fiducial number of data point nearest to click point

n/a

Grid Val

Value of grid cell at click point

Value of grid cell at click point (if grid dataset displayed)

Value of grid cell at click point (if grid dataset displayed)

Dist (m)

n/a

Distance from click point to nearest data point

Distance from click point to nearest data point

The following table describes the information shown under these headings during left mouse button drag query operations

Heading

Grid only

Line or Line + Grid

Point or Point + Grid

X, Y

X, Y coordinates of start point

X, Y coordinates of data point nearest to start point

X, Y coordinates of data point nearest to start point

Signal Field

n/a

Loaded Signal field name

Colour signal field name

Line

n/a

Line number of data point nearest to start point

Line dataset also present: Line number of data point nearest to start point

Line dataset not present: n/a

FID 1

n/a

Fiducial number of data point nearest to start point

n/a

Val

Value of grid cell at start point

Value of grid cell at start point

Value of grid cell at start point

Dist (m)

Distance between start point and finish point

Grid present: Distance between start point and finish point

Grid not present: Distance from data point nearest start point to data point nearest finish point

Grid present: Distance between start point and finish point

Grid not present: Distance from data point nearest start point to data point nearest finish point

Line, fiducial and point numbers

If the dataset has a line numbers alias (LineNumber), INTREPID uses the line numbers from this field.

If there is no LineNumber alias, INTREPID assigns line numbers to the data groups (lines) as they occur, starting with 0.

If there is a Fiducial alias, INTREPID uses the data in the fiducial field.

If there is no Fiducial alias, INTREPID assigns fiducial sequence numbers to the points as they occur in the dataset, starting with 0.

Screen redrawing

The Visualisation tool is designed to work with datasets of unlimited size.

Large datasets require lengthy processing and therefore screen redrawing may take some time. In order to show you the most up to data version of the datasets displayed, INTREPID performs redraws after most operations.

You can speed up redraws by reducing the sub-sampling rate of vector datasets. See Setting the display subsampling interval for instructions.

Due to our efforts to minimise screen redraws, INTREPID may fail to redraw the screen occasionally when you do require a redraw.

If you need to trigger a screen redraw

To trigger a screen redraw
  • Click the pan/zoom indicator square in the Command area or
  • Change the size of the Visualisation tool window slightly by dragging its border.

Setting the display subsampling interval

Each time you perform an operation or change an option, INTREPID redraws the screen. For a large vector dataset, this may take too long. You can speed up the display (at the cost of display detail) by reducing the subsampling interval. For example, if you set the subsampling interval to 2, INTREPID will only display every second data point on the screen.

You can set the subsampling interval separately for point and line datasets.

To specify the subsampling interval for line or point datasets:
  1. Ensure that you are using Zoom mouse mode.
  2. Choose Set Subsample Interval from the Line Display menu or Point Display menu. INTREPID displays the Subsampling for Display dialog box.
viwblisu.pngviwbposa.png

Specify the subsampling interval in the Interval text box and choose OK. INTREPID redraws the display with the new subsampling interval.

Note: Increasing the value of the Interval parameter means that INTREPID displays fewer data points.

Grid dataset display (single band)

If you are viewing a single band of a grid dataset you can choose pseudocolour, grey scale, sun angle or sun angle drape display. INTREPID uses sun angle drape when it first displays the grid.

Use the options from the Grid Display menu to specify your grid display method.

viwmgrid.png

Displaying grid datasets

To load a grid dataset
  1. Use Load Grid Dataset from the File menu.
  2. INTREPID prompts you specify the grid dataset, using an Open dialog box. See Specifying input and output files for details.
  3. If you specify a multiband grid, INTREPID displays the Select Band dialog box. Select the band you require and click OK. If you click Cancel, INTREPID loads the first band.
  4. viwbseba.png
  5. INTREPID displays the dataset. If there is already a grid dataset in the display, INTREPID replaces it with the new grid.
To turn grid dataset display on and off

Use Hide Grids in the Grid Display menu to show or hide the grid dataset you have loaded. The menu option has a check mark if grid display is hidden.

Pseudocolour display

If you choose pseudocolour display without modifying the Low Clip and High Clip parameters INTREPID will apply a fixed range pseudocolour display to your grid. This involves dividing the range of cell values in your grid into equal parts corresponding to pseudocolour values and assigning colours to the cell values accordingly. The 256 basic pseudocolour values are set out in the lookup table pseudocolour.lut (See “Colour Lookup Tables” in INTREPID database, file and data structures (R05) for details).

If you set Low Clip or High Clip values INTREPID will assign

  • The lowest ranking colour to all grid cells whose value is less than or equal to the Low Clip value.
  • The highest ranking colour to all grid cells whose value is greater than or equal to the High Clip value.
  • The other colours in the pseudocolour range to other cells in the grid on the basis described above.
To specify pseudocolour display for your grid
  1. Choose Grid With Pseudocolour from the Grid Display menu. INTREPID displays the Pseudocolour for Grid Dataset dialog box.
  2. viwbpseu.png
  3. Specify or reset Low Clip and High Clip values if required
  4. To restore the Low Clip and High Clip values to the minimum and maximum cell values, choose Reset. Otherwise enter the values (in signal units) in the corresponding text boxes.

  5. Choose OK.

INTREPID displays the grid using pseudocolour.

viwwfull00221.png

Grey scale display

If you choose grey scale display without modifying the Low Clip and High Clip parameters INTREPID will apply a fixed range grey scale display to your grid. This involves dividing the range of cell values in your grid into equal parts corresponding to grey scale values and assigning colours to the cell values accordingly. The 256 basic grey scale values are set out in the lookup table greyscale.lut (See “Colour Lookup Tables” in INTREPID database, file and data structures (R05) for details).

If you set Low Clip and/or High Clip values INTREPID will assign

  • The lowest ranking shade to all grid cells whose value is less than or equal to the Low Clip value.
  • The highest ranking shade to all grid cells whose value is greater than or equal to the High Clip value.
  • The other shades in the grey scale range to other cells in the grid on the basis described above.
To specify grey scale display for your grid
  1. Choose Grid With GreyScale from the Grid Display menu. INTREPID displays the Pseudocolour for Grid Dataset dialog box.
  2. viwbpseu.png

    The Low Clip and High Clip text boxes will at first contain the minimum and maximum cell values.

  3. Specify or reset Low Clip and High Clip values if required
  4. To restore the Low Clip and High Clip values to the minimum and maximum cell values, choose Reset. Otherwise enter the values (in signal units) in the corresponding text boxes.

  5. Choose OK.

INTREPID displays the grid using grey scale.

viwwgrey.png

Sun angle display and sun angle drape

Sun angle display creates the illusion of the sun shining on the image from a chosen angle, creating a system of illuminated areas.

The sun angle effect enables you to visualise the grid in terms of "hills" and "valleys". It interprets a high measurement in a sample as a hill and a low measurement as a valley.

You can use sun angle even though the measurements in the data may not actually be physical elevation. For example, if the measurements are levels of magnetism, the sun angle display allows you to visualise a "magnetic topography" where the hills are areas of high magnetism, and valleys are areas of low magnetism.

This display mode is useful for highlighting linear trends or breaks in the grid that may be missed in ordinary colour or grey scale coded viewing.

Sun angle display uses greys to show the sun angle effect.

Sun angle drape is a sun angle display draped over a pseudocolour display.

To specify sun angle or sun angle drape display for your grid
  1. Choose Sun Angle or Sun Angle Drape from the Grid Display menu. INTREPID displays the Sun Angle for Grid dialog box.
  2. gtviswin10.png
  3. Specify Declination, Inclination and Vertical Exaggeration as required, then choose OK. INTREPID displays the grid in sun angle format.

Declination is the compass direction of the line from the overhead point to the sun. A declination of 0° means that the sun is North of the overhead point. A declination of 90° means that it is East of the overhead point. –90° means West and ±180°or means South. The default declination is 45°.

Inclination is the angle of the sun between the horizon and the overhead point. An inclination of 0° means that the sun is on the horizon and an inclination of 90° means that it is at the overhead point. The default inclination is 45°.

Vertical Exaggeration is the size of the contrast between high and low values. If you increase the Vertical Exaggeration, the hills will appear higher and the valleys deeper. The default vertical exaggeration is 100.

Here are illustrations of sun angle and sun angle drape displays.

gtviswin11.pnggtviswin3a.png

Modifying the parameters of the current display format

You can modify the parameters of the current grid display format by choosing its menu option again (or applying an equalisation histogram).

To modify pseudocolour, grey scale or sun angle display parameters.
  1. Choose Grid with Pseudocolour or Grid with Sun Angle accordingly from the Grid Display menu. INTREPID displays the corresponding dialog box.
  2. Modify the parameters as required and choose OK. INTREPID displays the grid using the modified parameters.

Contours

You can place contour lines on a pseudocolour or grey scale grid display.

To display contour lines:
  1. Ensure that your grid is in pseudocolour or grey scale mode.
  2. Select Contour from the Grid Display menu. INTREPID displays the Contour Options dialog box.
  3. viwbcont.png
  4. Specify the contour interval in Signal data units and then click OK. INTREPID places a tick beside the menu option and displays the grid with contours.
viwwcont.png
To remove contours from the display:

Select Contours from the Grid Display menu, INTREPID removes the tick from the option.

Equalising histogram

If you are using the grey scale or pseudocolour display, you can use an equalising histogram to distribute the colours or shades so that each colour or shade has the same area in the display (the same number of grid cells).

To turn on the equalising histogram display
  1. Ensure that you are displaying the data using grey scale or pseudocolour.
  2. Choose Histogram from the Grid Display menu. INTREPID displays the Histogram Options for Grid Dataset dialog box.
  3. viwbhist.png
  4. Set the Bin Width parameter if required and choose OK. INTREPID places a tick beside the menu option and redisplays the grid using the equalising histogram.

Bin width In a piecewise linear histogram the data is grouped in bins according to rank. Each bin contains a fixed number of data items of similar value. The bin width parameter specifies the percentage of the data occupying one bin. The default value of .3 results in about 330 bins. If you increase the bin width, resulting in fewer bins, the data will have larger clusters and fewer different colours. If you decrease the bin width, resulting in more bins, the data will have smaller clusters and a greater variety of colours.

Restretch after every pan and zoom If you tick this check box, INTREPID reapplies the histogram each time you pan or zoom, recalculating the equal colour or shade distribution based on the visible area of the display.

Illustration below shows the normal pseudocolour and equalising histogram displays.

gtviswin6a.pnggtviswin8.png
+To turn off the equalising histogram display
  1. Choose Histogram from the Grid Display menu. INTREPID removes the tick from the option.
  2. If necessary, click the pan/zoom indicator box or slightly adjust the window size to force a screen redraw.

Ternary Grid display

This feature is for displaying radiometrics and other multiband grids.

You can display three grid bands at the same time, assigning bands to red, green and blue. You can use knowledge of colour addition to interpret the colours on the display. For example, a yellow area has red (potassium) and green (thorium). We can drape total count or magnetic data as sun angle display over the colours. The following table shows the appearance and normal purpose of each band in the ternary grid display. It lists the bands in the order that the Visualisation tool requests them

Band order in Visualisation

Purpose

Display

1

potassium

red

2

thorium

green

3

uranium

blue

When you specify a ternary grid for display INTREPID displays the grid band chooser dialog box for each band.

viwbseba.png

Select each band according to your requirements.

If you click Cancel for the Red band, INTREPID loads band 1.

If you click Cancel for the Green INTREPID loads the band number one greater than the Red band.

If you click Cancel for the Blue INTREPID loads the band number one greater than the Green band.

Here is an illustration of a ternary grid display.

viwwtern.png

Line Dataset display

The line dataset display has a large range of display options to enable you to both view and edit the dataset. You can:

  • Balance screen redraw speed with display detail (in Zoom mouse mode) by specifying the display subsampling rate. See Setting the display subsampling interval for details
  • Click any part of any traverse line using the mouse and view (for the nearest data point) the X and Y coordinates, the traverse line number, the number and fiducial number. See Querying points for details.
  • For a selected signal field, apply fixed range pseudocolour to the lines indicating values of the signal data. See Showing Signal values as line colour for details.
  • For a selected signal field, view the field as a profile superimposed on the traverse lines. See Viewing Signal data profile for details.

If you require a signal field for use in the display, specify it using the Load Signal Field for Line Dataset option from the Line Display menu (See Specifying input and output files for details).

You can control the line dataset display features using options from the Line Display menu.

viwmline.png

The following illustration shows a line dataset as the Visualisation tool originally displays it.

viwwline.png

Displaying line datasets

To load a line dataset
  1. Use Load Line Dataset from the File menu.
  2. If there is already a line dataset in the display, INTREPID displays the Add or Replace Point Dataset dialog box. See Displaying multiple vector datasets for instructions
  3. INTREPID prompts you specify the line dataset, using an Open dialog box. See Specifying input and output files for details. INTREPID displays the dataset.
To specify a Signal field for colour and profile display
  1. Choose Load Signal Field from the Line Display menu. INTREPID requests the signal field using a field choice dialog box.
viwbchlz.png
To turn line dataset display on and off

Use Hide Lines in the Line Display menu to show or hide the line datasets you have loaded. The menu option has a check mark if points display is hidden.

Showing Signal values as line colour

If you have specified a signal field you can display its values using fixed range pseudocolour. INTREPID will colour the traverse line paths in the display according to the value of the signal field. INTREPID assigns the colours from the pseudocolour.lut lookup table (See “Colour Lookup Tables” in INTREPID database, file and data structures (R05) for more information)

To display the signal field as line colour
  1. Ensure that you have specified a signal field (See Displaying line datasets).
  2. Choose Signal Value as Line Colour from the Line Display menu. INTREPID displays the line colours accordingly.
viwwzlco.png
To turn off Signal value as line colour display

Choose No Line Colours from the Line Display menu.

Viewing Signal data profile

If you have specified a signal field you can view a display of signal data as a profile. In this display INTREPID distorts the traverse line paths into ‘hills and valleys’ that illustrate the value of the signal field.

To display signal profiles
  1. Ensure that you have specified a signal field (See Displaying line datasets).
  2. Choose Show Profile of Signal from the Line Display menu. INTREPID displays the Profile Settings for Signal Field dialog box.
  3. viwbstac.png
  4. Specify the parameters according to your requirements and choose OK. INTREPID displays the signal Profiles.
  5. Offset The Offset is the relative height of the profile display in signal units per display centimetre. INTREPID subtracts the signal data base value before calculating the profile height.

    Base Value In the context of profile display in the Visualisation Tool, we recommend that you use a base value of 0.

    viwwstac.png
  6. Adjust the parameters as required by turning off stack profile display (select the menu option again) and then repeating steps 1 and 2 above.
To turn off display of the signal stack profile

Choose Show Profile of signal from the Line Display menu. INTREPID will redraw the display without the signal profile.

To modify the signal stack profile parameters

Turn signal stack profile display off, then on again. When you turn it on INTREPID displays the Profile Settings for signal Field dialog box again (see above for instructions).

Point dataset display

You can display a point dataset using square or angled line markers. INTREPID can vary the size, colour and angle of the markers according to the values in signal fields. Specifically, you can select signal fields whose values determine:

  • Size of square point markers in the display
  • Colour of the point markers in the display
  • Angle of line-shaped point markers in the display
  • Labels for the points displayed.

You can turn these aspects of the display on and off as required.

If you enable angle display, the point markers are line-shaped. If you disable this display, the point markers are square.

In each case INTREPID assigns the sizes, colours or angle according to a fixed range system, where each size or colour has a value range the same size. INTREPID assigns the colours from the pseudocolour.lut lookup table (See “Colour Lookup Tables” in INTREPID database, file and data structures (R05) for more information) INTREPID assigns sizes and angles according to the range of Signal values.

You can balance screen redraw speed with display detail (in Zoom mouse mode) by specifying the display subsampling interval. See Setting the display subsampling interval for details

The following illustration are of Bouguer Anomalies from the guided_tours/Intrepid_datasets/EBA_DBs/Gravity_Point_Data..DIR point dataset. The Boug field is used as point colour and size.

viwwpoin.png

Displaying point datasets

To load a point dataset
  1. Use Load Point Dataset from the File menu.
  2. If there is already a point dataset in the display, INTREPID displays the Add or Replace Point Dataset dialog box. See Displaying multiple vector datasets for instructions
  3. INTREPID prompts you specify the point dataset, using an Open dialog box. See Specifying input and output files for details.
  4. After you specify the dataset, INTREPID requests fields for colour, marker size, marker angle and marker text, using a field choice dialog box. If you don’t want to specify a field for a display attribute, click Cancel for that attribute.
  5. viwbchsz.png
  6. After you assign fields to the display attributes, INTREPID displays the dataset.
To turn point dataset display on and off

Use Hide Points in the Points Display menu to show or hide the point datasets you have loaded. The menu option has a check mark if points display is hidden.

Changing the colour, size and angle for signal field selection

To assign signal fields to colour, size, angle or text

If you did not specify a signal field for colour, size or angle and now want to do so, use Signal Value as Point Colour, Signal Value as Point Size, Signal Value as Marker Angle or Signal Value as Text from the Point Display menu. INTREPID displays an Open dialog box.

To reassign signal fields to colour, size, angle or text

If you want to change your signal field selection, reload (and replace) the point dataset using Load Point Dataset from the File menu, and specify the colour, size, angle and text fields as required.

To turn colour, size, angle or label display on and off

Once you have specified a signal field, choose the Signal Value as Point Colour, Signal Value as Point Size, Signal Value as Marker Angle or Signal Value as Text from the Point Display menu to turn the display on or off. The options have check marks against them if they are turned on.

viwmpoin.png

Polygon dataset display

You can include polygon datasets in the display in two ways, with or without labels:

  • Load and display existing polygon datasets
  • Trace new polygons and save them as polygon datasets if required.

Use the Polygon Display menu to control polygon display.

viwmpoly.png

Displaying existing polygon datasets

To load an existing polygon dataset
  1. Choose Load Polygon Dataset from the File menu. INTREPID displays an Open dialog box.
  2. Specify the polygon dataset you require. (See Specifying input and output files for instructions). INTREPID displays the Optional Label Field dialog box.
  3. viwbchtg.png
  4. If the dataset has a label field, select the field and click OK (You can turn label display on and off). Otherwise, choose Skip. INTREPID displays the dataset.
To add a label to an existing polygon dataset

Before loading the dataset into the Visualisation Tool, use the Spreadsheet Editor to add a new group by text field. We normally use the field name Tag. See Spreadsheet Editor (T15) for instructions.

Creating new polygons and polygon datasets

To trace a new polygon in the display
  1. Select Zoom or Trace mouse mode.
  2. Choose Trace a Polygon from the Polygon Display menu.
  3. Click the vertices of the polygon you require. Do not attempt to close the polygon by clicking points.
  4. Choose Close Traced Polygon from the Polygon Display menu. You may need to redraw the display before the last line of the polygon appearers.
viwwtpol.png
To save a traced polygon as a new polygon dataset
  1. Trace and close the polygon.
  2. Choose Save Traced Polygon As from the Polygon Display menu. INTREPID displays the Traced Polygon Label dialog box
  3. viwbplbl.png
  4. Specify a label for the polygon and click OK. INTREPID stores this in the Tag field of the dataset. INTREPID displays a Save As dialog box.
  5. Specify the name of the new dataset. See Specifying input and output files for instructions.
To erase a polygon you have traced.

Choose Erase Traced Polygon from the Polygon Display menu.

Controlling polygon display

To turn label and polygon display on and off

Use Hide Labels in the Polygon Display menu to turn label display on and off.

Use Hide Polygons in the Polygon Display menu to turn polygon display on and off.

Help

You can use the Help menu to display help text on the topics shown in the menu illustration below.

viwmhelp.png

Exit

To exit from Visualisation Tool choose Quit from the File menu.

Displaying options

To display the current line dataset file specifications and a record of any line editing you have performed, choose Report from the Window menu.

viwmwind.png

INTREPID displays the Visualisation Tool Report window containing this information.

viwwrept.png

Frequently asked questions

Q : What kinds of point datasets are there?

Point datasets include the following:

  • Random point data such as terrestrial gravity observations, geochemical survey data.

Any type of data that is not collected along a series of regularly spaced lines, must be imported into INTREPID as a point dataset. Even if you collected the data along lines, you must organise this data into a series of lines to reflect this before import. If the data is not grouped into lines, you have to imprt it into a point dataset.

For example, magnetic data can sometimes be transported as text files containing only XYZ values. In this case the line structure reflecting the way the data was collected has been lost.

  • INTREPID can generate point datasets from existing gridded or line data. The most important are:
  • Point datasets of depth estimates plus other attributes, generated by the Euler deconvolution tool . See Euler deconvolution (T44).
  • Point datasets of depth estimates plus other attributes (such as dip, strike, magnetic susceptibility), generated by the Naudy Automatic Modelling tool. See Naudy Automatic Model interpretation (T43).
  • Point datasets of anomaly points, which indicate the maximum and minimum anomaly points in a dataset, generated by the Magmage Magnetics Interpretation tool. See Magnetic interpretation (MagMage) (T42).

These Point datasets can contain few or many attributes. At the very least they will contain X and Y spatial information plus at least one signal field.

The following table shows the number of signal fields contained in a number of point dataset types.

Points Dataset Type

No of Signal Fields

Trend (MagMage)

4

Anomaly (Gridding)

7

Euler

13

Naudy

25

Q : What are the conventions for displaying datasets?

There are no hard and fast conventions for displaying datasets. We often find the most effective way through trial and error.

INTREPID displays a plan view of data. This is adequate for datasets that are essentially 2 dimensional, such as grids, line data and point data.
Point datasets with a depth field, such as Naudy and Euler datasets, are three dimensional. To help us visualise this data meaningfully, INTREPID provides the four point display attributes colour, marker size, marker angle and marker text.

Q : What field should I assign to each attribute in a point dataset display?

Point dataset display has four display options – colour, marker size, marker angle and marker text.

Generally, use colour for the primary signal field, size to highlight reliability of the data, and marker angle for direction attributes like bearing or body strike.
These are only guidelines – you might well use symbol size to distinguish data of different ages, or colour to highlight data that fulfils a certain condition. It really depends on the task at hand and how you prefer to visualise data.

For a typical two dimensional point dataset such as one with gravity data, you would generally assign the primary signal field (gravity value) to point colour.

For a point dataset containing trend information, assign the primary signal field (gravity or magnetic value) to point colour and the bearing field to marker angle.

For a point dataset containing anomaly points information, assign either the signal field or the structure attribute to colour, and direction to marker angle.

For point datasets containing a depth attribute, assign depth to colour. You can assign reliability to marker size and this will give a sense of how significant the data point may be. Assign strike to marker angle.

Q : Do you have any tips or conventions about line or grid dataset display?

  • Ternary grid dataset display is for Potassium, Uranium, Thorium radiometric grids to create a ternary (RGB) display.
  • You can use spatial convolution to change a grid before displaying it. INTREPID has an extensive library of convolution kernels. Use the grey scale option for display. See Spatial convolution grid filters (T34) for details.