↑ Top
Table of Contents

Introduction to INTREPID (R02)

INTREPID overview

INTREPID is a geophysical processing, visualisation and hard copy printing tool. It assists you to process, analyse, interpret, display and print geographically located data. It is fully integrated with a consistent graphic user interface. You can use it in both batch and interactive modes.

Using INTREPID you can:

  • Import data from binary, ASCII, ASCII database and other industry standard file formats;
  • Directly process data in many formats including Geosoft, ERMapper, NetCDF, ZYCOR, EDI, SEGY and Oracle data.
  • Process 3D grids (voxets) and surfaces (for example, DXF)

Note: These are also progressively being added to the low level drivers and elementary editing support is now available in the editors.

  • Export data in binary, ASCII, ASCII database and other industry standard tape or file formats;
  • Convert data between datums and projections (INTREPID supports all common worldwide datums and projections);
  • Integrate data that have different datums and projections;
  • Use user definable datums and projections;
  • Edit data graphically in time or space or in a spreadsheet. Editing facilities include search and replace, ramping (eliminating sudden changes near edited data), creating new fields with values calculated from other fields;
  • Display statistics and histograms of data. This includes all the emerging Tensor gradient formats;
  • Display the history of processes performed;
  • Correct and extract key channels from radiometric data;
  • Edit, level, filter, decorrugate and microlevel your line data using special purpose line data processing tools;
  • Create grids from line or point data, interpolating empty cells;
  • Subsection, stitch, append, merge and resample line, point and grid data;
  • Apply spatial convolution filters, Fast Fourier Transforms and spectral domain filters to lines, grids and voxets;
  • Display point and line datasets, and single and multiband grids using grey scale, colour or sun angle, with geographical annotation;
  • Crop, pan and zoom dataset displays;
  • Adjust the colour/shade range of a display by linear or histogram colour stretching;
  • Align and overlay sets of points, lines and/or polygons from other sources onto grids, and display them using a style of your choice
  • Prepare and print maps containing your data with a wide range of data-linked and simple annotations, including your own logos, etc;
  • Identify highs and lows with ‘worm’ diagrams and locate incoherencies in magnetic grid data using the MagMage software;
  • Calculate solutions and source depth estimations for observed phenomena using Euler, WormE and Naudy methods. These tools also calculate 3D surfaces and objects.

Processing your survey data

The INTREPID Geophysical Data Processing tools prepare and grid data from several remote sensing techniques. Among the most important for mapping are

  • Aeromagnetic surveys,
  • Gravity & Gravity gradiometry surveys,
  • Radiometric surveys,
  • Electromagnetic surveys,
  • Digital terrain surveys.
  • Seismic data as a time series vertically along a profile.

INTREPID can prepare the raw survey data, grid it and produce high quality images.

The ability to process large datasets and splice a number of surveys is one of INTREPID’s specialties.

Argus compatibility

Intrepid supports close links to Argus. The shared systems between the two environments ensures strong interoperability, with many of the specialist geophysical operations available in Intrepid, but ultimately preparing data suitable for creating and aiding the geology model creation portion of Argus. Likewise, most of the geophysical operations required within the Argus tool are spawned INTREPID processes.

INTREPID requirements and conventions

INTREPID programming and portability

Historically, INTREPID is written in C++ using the InterViews graphical user interface toolkit. More recently developed applications use Java for the graphical user interface. Batch processes use one of two possible syntaxes for process description, historically the INTREPID "job file syntax" was use, this has since been deprecated.

INTREPID now utilises Google’s "protobuf syntax" for its batch processes and interactions with its API.

We are also making the transition to multi-processor enabled code.

Equipment and operating systems required

You can use INTREPID on computers running 64 bit versions of Windows Server 2008 R2 or later, Windows 7, Windows 10 and Linux Ubuntu 14. There is no support for 32 bit computers, Solaris and other Windows versions unless mentioned here.

INTREPID requires a minimum of 2 Gb of memory. The Windows version requires approximately 250 MB disc space for the software. Demonstration and Guided Tour data add significantly to this (up to 200 MB).

We do not currently recommend the touch screen interface with INTREPID but touch-enabled screens should still work properly when you use mouse or keyboard.

Units of measure

INTREPID allows you to use any distance unit that you wish with projected data. You should prepare and input data in the unit required (usually metres).

For data with geographical coordinates the distance unit is fractional degrees. In general, INTREPID will automatically convert geographical coordinates imported or specified with colons separating degrees, minutes and seconds (the format d:m:s, e.g., 143:34:01.24 for 143° 34’ 1.24" will be stored as 143.56701°). Contact our technical support service if you need assistance with data in this format.

INTREPID maintains the distance unit throughout its operations. For example, if you input data in metres, INTREPID will output data in metres.

Notation and language in this manual

Fonts and styles

  • We show the names of files, the text of commands and the contents of text files associated with INTREPID in monospaced font.
  • We show the names of system parameters and environment variables in capitals, e.g., INTREPIDBIN
  • We show values of system parameters or environment variables in monospaced font, for example, 1024.
  • In the text of a code file, for example in task specification (.task) files, we specify that the value of a system parameter or environment variable should be substituted by using the notation, for example $INTREPIDDATA
  • We show language and notation specification (metalanguage) in monospaced font italics. For example, ’You must specify a function as name(argument).’

X, Y, Signal, and Height data

In this manual we frequently refer to X, Y and Signal data. We also refer to vertical position in various ways.

X and Y data is the location data, consisting (respectively) of Easting and Northing or Longitude and Latitude data.

Signal data is the data that has been recorded or interpolated for the location specified by X and Y, e.g., magnetic, radiometric, gravity. Thus each point in a dataset will normally have only one X and Y value but may have a large number of Signal.

If you maintain X and Y in different datums or projections or correct the X and Y data to make its location more accurate, a point may have two or more sets of X and Y data. Only one set can be the ’official’ set at any time. The field names of the ’official’ coordinates are assigned to the X and Y aliases in the INTREPID standard information (.isi) file of the dataset.

The use of Z to describe vertical location is a source of confusion in geophysics. For example, GPS height is referred to as Z and the vertical derivative as dM/dZ.

In this reference manual we will use the terms clearance, height and altitude to refer to vertical location. If a situation arises where we need to describe someone else’s use of Z for vertical location data, we will clarify it and set out a method of avoiding confusion.

Tip: INTREPID is generally moving to use the term Signal rather than Z to describe a signal field.

Measures of height INTREPID uses a variety of vertical position measures. The following table shows our conventions for naming height measurements. At the time of writing, we are still in the process of revising the INTREPID user interface and documentation to conform to this standard.

Term

Usage

Clearance
(Ground Clearance)

Distance from the instrument to the ground

Depth
(marine survey)

Distance from the instrument to the ocean floor (similar to clearance)

Depth (interpretation)

Distance from the instrument to the top or edge of an inferred geological structure

Height

(1) Distance from the instrument to the surface of an ellipsoid. We always indicate the datum to which the height refers. (For example, GPS Height is the distance from the instrument to the WGS84 ellipsoid.)

(2) Generic height. We use height when it is not necessary to distinguish the vertical position measure.

Terrain Height

Distance from the ground to a datum

Altitude

Distance from the instrument to the Geoid (mean sea level)

Terrain Altitude

Distance from the ground to the Geoid (mean sea level)

Z

We use Z for vertical position. Historically Z has been also used for "Signal".

Aircraft, flights, ships, cruises

We use the term flight and refer to aircraft frequently in this manual, because a majority of sensing work is aircraft-based. In fact, you could have used a variety of craft to acquire the data. For marine data, such as marine gravity, we use the terms cruise and ship. In the current version of INTREPID documentation, the various words for ‘excursion’ and ‘sensing craft’ are interchangeable. For example, you can readily use the Survey Path Editor tool to edit data from a cruise.

Wavelength, frequency, wave number

These terms are all used to describe waves in data.

Wavelength is measured in a distance unit such as metres or kilometres.

Frequency, strictly speaking, is related to time. The unit Hertz, for example, indicates cycles per second.

In these manuals we set out to minimise jargon and use common language if possible. We loosely use the term ‘frequency’ with respect to distance, (e.g., cycles per kilometre). In this context,

Frequency = 1 / Wavelength.

Wave number is the correct term for describing wave cycles per distance unit (e.g., cycles per kilometre).

Wavenumber = 1 / Wavelength.

We have chosen to use the more colloquial term ‘frequency’, since its meaning is still clear in the contexts concerned and it simplifies the text.

System parameter and environment variable $ notation

In this manual the notation $INTREPID_MEMORY means the value of the system parameter or environment variable INTREPID_MEMORY. You can generally use this ’$’ notation with system parameters and environment variables in general. There is one exception to this rule. See INTREPID system parameters and install.cfg (R07) for a full description of INTREPID’s system parameters and environment variables.

INTREPID with different platforms

A significant feature of INTREPID is that you can seamlessly access all data and procedures from any platform on which INTREPID can run. In particular, INTREPID software automatically and transparently takes care of any endian (byte order) data issues.

There are some minor differences between INTREPID’s operation under Linux and under Windows. If you are accessing INTREPID data with both platforms you will need to attend to some of these differences. See “Accessing INTREPID data from both Linux and Windows” in Configuring and using INTREPID (R04) for more information.

INTREPID datasets and file structure

INTREPID stores all data in the standard INTREPID dataset format. The following section describes the basic features of INTREPID datasets. See INTREPID database, file and data structures (R05) for further more information.

Dataset types

There are four types of INTREPID dataset

Dataset type

Description

Grid

rows and columns of cells

Vector

Point

sets of data points

Line

sets of data points along traverse lines

Polygon

sets of points for defining regions of interest

INTREPID datasets consist of one or more files.

Grid datasets have all data in a single file, with a number of auxiliary files that provide information about the grid.

Vector (Point, Line and Polygon) datasets have a separate file for each field (a ’field file’) (e.g., separate files for the X, Y and Signal Data). An index file synchronises the data in these files. INTREPID stores all of the field files for a vector dataset in a single dataset directory.

Multiband datasets

INTREPID can create and use multiband data, where each grid cell or data point signal field can have several values.

Multiband Grid datasets normally use a Band Interleaved by Line format. INTREPID can also use Band Interleaved by Pixel grid datasets.

Point and Line datasets can also have multiband fields.

See INTREPID database, file and data structures (R05) for full details of multiband dataset structures.

Aliases in the INTREPID standard information (.isi) file

You may wish to use a variety of file names for the fields and have several versions of some fields (e.g., uncorrected and corrected X and Y data). If you have several X fields, for example, INTREPID needs to know which X field is the one you wish to use.

The INTREPID standard information (.isi) file contains a list of the ’roles’ in the vector dataset and the name of the field that is ’playing’ each ’role’ Each role has an alias which INTREPID uses to refer to the field concerned. The common aliases are X, Y (location), LineNumber, Line Type, Fiducial and FlightNumber.

See “Vector dataset field aliases” in INTREPID database, file and data structures (R05) for further details.

Data precision and null values

See INTREPID database, file and data structures (R05) for a full description of the data precisions available under INTREPID.

If data is missing from a dataset its place must usually still exist in order to maintain integrity of the data. INTREPID assigns null, a special value, to the missing data See INTREPID database, file and data structures (R05) for a list of the value of null for each data type.

File names for INTREPID data

For information about rules for filenames in INTREPID, see “INTREPID file names” in INTREPID database, file and data structures (R05).

INTREPID auxiliary files

INTREPID uses a system of auxiliary files for various purposes such as defining specifications and setting parameters. These are text files with a standard syntax consisting of { } or Begin – End blocks enclosing keyword=value or keyword : value declarations. See “INTREPID Auxiliary files” in INTREPID database, file and data structures (R05)

Task and hard copy specification and HISTORY files

Task specification (.task) and (legacy) (.job) files

Task specification files are text files containing the specifications for tasks to be performed by INTREPID tools. These files have names that end in.task. They are text files with Protocol Buffers (Protobuf) structure – { – } block syntax. For examples of these files see the example below and also INTREPID task, HISTORY, report and log files (R06).

We continue to support the legacy task file notation (.job files). See “INTREPID Auxiliary files” in INTREPID database, file and data structures (R05) for a description of this syntax and INTREPID task, HISTORY, report and log files (R06) for more examples). You can generate a legacy notation (.job) task specification file using Save Taskfile or Save Options from the File menu in most INTREPID tools.

Tip: After creating the file it may be more convenient to directly edit it with a text editor than to adjust settings before repeating a process than using the INTREPID tool’s graphic user interface to adjust and save it.

In future releases of INTREPID we shall extend the Protobuf (.task) file system to operate interactively with the individual tools in the same way as the legacy (.job) files currently do.

The Project Manager tool has a .job to .task file converter. See “Converting legacy Parms (.job) files to Protobuf (.task) files” in INTREPID Project Manager (T02).

Here is an example of a .task specification file.

IntrepidTask { ProjConv { ToolName : "projconv"; ToProj : "TMAMG51"; ToDatum : "AGD66"; OutputMesh : 300.00; Angle : 0.0000000; InputImage : "mag_568"; OutputImage : "mag_568_AMG51"; } }

See INTREPID task, HISTORY, report and log files (R06) for general information about these files and examples.

For a discussion and example of task specification file format for a particular tool, see the section "Displaying options and using task specification files" at the end of the chapter describing the tool.

HISTORY files

Whenever you use INTREPID, it records your activities in a history file. The history file is a text file with the name HISTORY. It can act as an audit trail for your processing. HISTORY has the same format as task specification files (see Task specification (.task) and (legacy) (.job) files). You can extract sections from it to use in task specification files or even use a whole history file for a batch task. INTREPID stores the history file in a project directory.

See also:

Hard copy specification (.map) files

If you use the Hard Copy Composition tool or MAPCOMP language you will save your work in hard copy specification files. These are text files that have names ending in .map. See MAPCOMP map specification language (R20) for further information.

INTREPID data compatibility

You can

  • Access INTREPID datasets using a number of other software packages.
  • Use INTREPID to process Geosoft datasets in their native format.
  • Use INTREPID to process ERMapper grid datasets.
  • Import data to INTREPID from a wide range of file and dataset formats.
  • Export INTREPID datasets to a wide range of file and dataset formats.

Accessing INTREPID datasets using other software

See “Accessing INTREPID datasets and tools using other software” in Configuring and using INTREPID (R04)

INTREPID access to datasets created by other software

See “Accessing data created by other software” in Configuring and using INTREPID (R04) and INTREPID direct access, import and export formats (R11)

Using INTREPID

You can use INTREPID interactively or in batch tasks which use prepared task specification (.task) or hard copy specification (.map) files. In this section:

The HISTORY file location, project directory, working directory

You need to read all three of the following sections to see how the three elements fit together.

Location of the HISTORY file

Each project directory has a history file (called HISTORY) that contains a record of all processes that you have carried out on its datasets. You can use the history file as an audit trail for your operations or as a source of text for constructing task specification files. See INTREPID task, HISTORY, report and log files (R06) for information about using these files. See also HISTORY files.

Project directory

When you first start using INTREPID somewhere in your directory tree, INTREPID establishes the working directory as a project directory and creates a HISTORY file in it. From this point onward, INTREPID uses this HISTORY file whenever the working directory is the project directory or a subdirectory of the project directory.

If the working directory is not part of a project, INTREPID will establish it as a new project.

Warning: It is possible to accidentally create a project within a project. You can do this if you launch an INTREPID tool with a working directory that is the parent of a project directory. To avoid confusion we suggest that you avoid this practice. If you do it accidentally, simply delete or rename the files called HISTORY and ProjectInfo in the directory that is not meant to be a project directory.

See “Projects – file and directory structure” in INTREPID database, file and data structures (R05) for an example of the project directory.

Working directory

Whenever you use an INTREPID tool, INTREPID uses the directory that you set at the time that you launched the tool. This applies both for Batch Process Manager command-line operation and within the Project Manager. We call this the working directory.

  • Whenever you attempt to load or save a file or dataset, INTREPID will generally display the contents of the working directory in the load or save dialog box.
  • Under Linux, the Path text box in load and save dialog boxes will show the path of the directory currently listed either relative to the working directory or in full depending on the tool you are using.
  • When you launch an INTREPID tool, INTREPID will search up the directory tree from the working directory to establish whether this directory is part of an existing project. If it finds a HISTORY file, it uses this. If it does not find a HISTORY file, it establishes the working directory as a new project and creates a HISTORY file in it

How to start INTREPID – Overview

See also:

To start INTREPID for an interactive session

For working with datasets using INTREPID launch the INTREPID Project Manager. Under Windows:

  • From the Start menu, choose Intrepid6 > Intrepid Project Manager. OR
  • From the bin folder in the folder where you installed INTREPID, run jfmanager.exe

For visualising datasets using INTREPID launch 3D Explore. Under Windows:

  • From the Start menu, choose Intrepid6 > Intrepid 3D Explore. OR
  • From the bin folder in the folder where you installed INTREPID, run 3DExplore.exe

You can use individual INTREPID tools interactively:

  • Through the Project Manager menus or
  • Alone, using the corresponding .exe file in the bin folder of your INTREPID installation.

You can also use tools through batch tasks. Task or Hard Copy specification (.task or .map) files provide specifications for batch tasks or initial sets of options for interactive sessions.

You can use most INTREPID tools with task specification (.task) files in interactive or batch mode. See “Using task specification files” in INTREPID task, HISTORY, report and log files (R06) for details.

Warning: This section refers to task specification (.task) files. The Map Composition and Print Map tools use hard copy specification (.map) files rather than .task files. If you are using either of these tools with specification files, you must specify map specification (.map) files instead of .task files.

See INTREPID task, HISTORY, report and log files (R06) and MAPCOMP map specification language (R20) for detailed information about these files.

The following table shows the methods of launching and executing INTREPID tasks with and without task specification (.task) files.

Launch from Menu

Launch by Command Line

Without .task file

With .task file

Without .task file

With .task file

Interactive Execution

Use Project Manager menu option to launch tool interactively.

Use Project Manager menu option to launch tool interactively, then use menu option File > Open Taskfile....

Use command for tool.

Use command for tool with -input switch and .task file name.

Batch Mode Execution

In Project Manager* window: Right click .task file and choose Launch batch process.

Use command for tool or Batch Process Manager* (fmanager.exe) with -batch switch and .task file name.

* The Batch Process Manager (command line batch mode):

  • Has more sophisticated batch processing capabilities than individual tools,
  • Can recognise and process task specification files for all tools,
  • Has automatic task progress monitoring (See Configuring and using INTREPID (R04).

How to start INTREPID – Interactive mode

You can launch INTREPID tools in interactive mode independently or through Project Manager.

Project Manager enables you to perform file management tasks, select working directories and launch other INTREPID tools from a menu bar.

Once you have launched a tool you can interactively specify the task you wish it to perform or load a prepared task specification (.task) file. You can also launch a tool and automatically load a .task file with it.

To launch Project Manager

Choose the Project Manager icon or menu option, or use the command jfmanager.exe. The method you use depends on your version of INTREPID and the way you have it set up on your menu or applications launch screen. See INTREPID Project Manager (T02) for detailed instructions.

To launch INTREPID tools from the Project Manager
  1. Set the working directory you require for your process (see “Selecting datasets and files” in INTREPID Project Manager (T02)).
  2. If required, select the dataset to be processed (see “Selecting datasets and files” in INTREPID Project Manager (T02))
  3. Choose the tool you require from the corresponding Project Manager menu (see “Launching INTREPID tools and processes” in INTREPID Project Manager (T02)).
To launch INTREPID tools independently of Project Manager

Note: To do this you need to have added the INTREPID install path to the PATH environment variable in your operating system or shell. See “Including the INTREPID installation directory in PATH” in INTREPID system parameters and install.cfg (R07)

Set the working directory you require for your process, then type the name of the main executable file for the tool as a command (e.g., fedit.exe for the Survey Path Editor tool).

If you have a prepared task or hard copy specification (.task or .map) file for the task, add the -input switch and the name of the .task or .map file to the command line. Task specification files used for interactive launch in this way may only contain a single task. If the .task file contains the correct specifications for your task, simply choose Apply in the tool’s main window.

For example

fedit.exe -input serv.task

How to start INTREPID – Batch mode

You launch a batch task using an INTREPID tool by typing the command line for the tool with the -batch switch and the name of the prepared task or hard copy specification (.job, .task or .map) file.

You can also launch tasks in batch mode using:

  • Project Manager interactively to launch the Batch Process Manager or
  • Batch Process Manager on the command line using the command fmanager.exe.

If you use Batch Process Manager, you can combine a number of tasks into a single task specification (.task) file. These tasks can use different INTREPID tools as required by you. The Batch Process Manager performs the tasks one after the other as they appear in the task specification (.task) file.

The Print Hard Copy tool is the only tool which accepts .map files in batch mode.

INTREPID automatically creates a task progress report as it executes batch tasks. See “Displaying diagnostic information from Log files” in INTREPID Project Manager (T02) for further details.

To launch a batch task by command using an individual INTREPID tool

Set the working directory that you require for the process. Type the name of the main executable file for the tool as a command, including the -batch switch and the name of the prepared task or hard copy specification (.task or .map) file. In this case a .task file may only specify a single task for the tool you are using. For example,

To perform gridding using the task specification file ebagl23.task use the command

gridding.exe -batch ebagl23.task

To print hard copy specified by the file ebagoola_mag1.map, use the command

mapprint.exe -batch ebagoola_mag1.map

To launch INTREPID tools interactively from the Project Manager with Batch Process Manager executing them in batch mode using a task or hard copy specification (.task or .map) file
  1. Launch the Project Manager (see INTREPID Project Manager (T02) for detailed instructions.)
  2. Locate and select the .task or .map file (see “Selecting datasets and files” in INTREPID Project Manager (T02)).
  3. From the shortcut menu (right-click the file) select Launch batch process
To launch a batch task by command using Batch Process Manager

Note: To do this you need to have added the INTREPID install path to the PATH environment variable in your operating system or shell. See “Including the INTREPID installation directory in PATH” in INTREPID system parameters and install.cfg (R07)

Set the working directory that you require for the process. Type the command for Batch Process Manager, including the -batch switch and the path and name of the prepared task specification (.task) file. Task specification files used in this way may contain more than one task and may use more than one INTREPID tool.

For example, to execute the task specification file ebagl23.task use the command

fmanager.exe -batch ebagl23.task

Note: The command is fmanager.exe, not jfmanager.exe.

INTREPID tools – commands and modes of operation

There are differences between INTREPID tools in their possible modes of operation. Some INTREPID tools do not offer all of the following:

  • Interactive mode operation,
  • Loading task or hard copy specification files in interactive mode (.task files are used except for Mapcomp and Mapprint which use ‘.map’ files),
  • Batch mode operation,
  • Updating HISTORY files (audit trails) to record operations.

Geosoft Oasis montaj access to INTREPID tools

See also “Accessing INTREPID datasets and tools using other software” in Configuring and using INTREPID (R04).

To use INTREPID tools from within an Oasis montaj session
  1. Copy the contents of the {install_path}/Oasis/OMN directory to your local OMN directory (where {install_path} is the location of your INTREPID installation).
  2. In Oasis, go to the GX Load menu and choose the Intrepid option.

The INTREPID graphic user interface

INTREPID operates under a conventional graphic user interface.

Motif compliance

When it is running under Linux, INTREPID uses the Motif graphic user interface system.

Windows compliance

When it is running under Windows, INTREPID complies with the standard Windows graphic user interface.

We assume that you already know:

  • The concept of disc directory structure – directories, subdirectories, ‘parent’ directories, the working directory, etc.,
  • How to click, double click and drag with the mouse,
  • How to select, move and resize windows.
  • How to recognise and use pulldown menus, dialog boxes, command buttons, option buttons, check boxes, text boxes, list boxes, scroll bars and sliders.
  • How to select items from a list box by double clicking with the left button or clicking then pressing return or choosing OK.

INTREPID tool windows

Many INTREPID tools have a standard window layout as shown in the following diagram and description.

intwindo.png

Menu / toolbar contains the controls for frequently changed options and parameters to which you need ready access. It may also contain information about the data being examined or processed.

Data display area contains a graphic display of the data being processed or examined.

Apply button For tools other than editors, after you specify the input and output files and parameters for a task you choose the Apply button to execute the task.

Show button If you select the Show button, INTREPID will open a .txt file containing a report of parameters used. This is an uncommon feature and has been replaced by automatic report files, .rpt, being generated following processing, which are opened in your default text editor. To observe parameters being used by the tool, you can choose File > Save Options / Save Task. See INTREPID task, HISTORY, report and log files (R06).

Report window This contains a list of the settings you have specified for the task. It is, in fact, a copy of the task specification file that INTREPID would use for the current task. This window can be found under Window > Report in some tools.

reprtwin.png

Specifying groups of parameters in dialog boxes

Sometimes INTREPID requires you to specify a group of parameters in a single text box in a dialog box. You should enter or edit the parameters so that you separate each pair of parameters by one or more spaces. Here is an example:

level_select_polynomial_defaults.png

Help

At any stage while you are using INTREPID you can obtain on-screen help using the Help menu provided in each tool’s window.

toolhelp.png

When you select Help, INTREPID opens the related user manual in your default pdf viewer. This Help button links to its respective Tool Reference, for more beginner friendly material, refer to the Guided Tours found from launching help in the Project Manager.

Specifying input and output files

Most INTREPID tools require you to choose an input file and specify an output file. INTREPID provides a standard procedure and set of dialog boxes to assist you to choose files. This section of the manual describes the standard procedure for specifying files for loading and saving.

After you specify a file INTREPID will record it for use with the current application. If the file is an input file, INTREPID may open it, examine its contents, or display some data from it, depending on the circumstances.

If you are specifying vector data, you may need to specify separate X, Y, Z and other component files. In this case, INTREPID will automatically display the next required file selection dialog box. (You can usually avoid this sequence of dialog boxes by having aliases properly configured in the INTREPID standard information (.isi) file.)

In some INTREPID applications you may need to specify a number of parameters and options besides the input and output files. When you have specified all requirements for the operation, you will normally choose Apply. INTREPID will then load the input file, process the data and save the results in the output file.

In some applications INTREPID may immediately load and display input files and save output files.

You can specify the name of a file for input or output by choosing Open... , Specify input file..., Save as... or Specify input file... from the File menu.

impmfile.png

File selection dialog boxes are similar throughout the INTREPID tools. They each have a title appropriate to their purpose, and other variations such as their mask (see below).

If you have already selected a dataset, INTREPID usually displays a field selector dalog box for you to select the field you require.

The file selection boxes shown here are typical across INTREPID tools.

intbvecw.pngintbself.png
To specify a file for loading or saving
  1. Choose Load, Open or Save As or other required option from the s menu or other place in the tool.
  2. Navigate to the directory that contains or is to contain the files in the normal way for Windows Open and Save As dialog boxes (This step does not apply if INTREPID displays a field selector dialog box). Alternatively you can type the full or relative path specification for the file in the selected file display box.
  3. If you are loading a file and its name shows in the list box, double click its name to select it (or click then press return.
  4. If you are saving a file, when you have selected the correct target directory, type the name of the file in the Save As text box (or select an existing file if you are overwriting it).

  5. Choose Load/Open or Save.

The Directory Contents list box and Path text box (Linux)

When you first display a Load or Save dialog box, INTREPID displays the contents of the working directory (set as you launched the tool). INTREPID displays the directory contents in a list box. You can navigate through the directory tree and display the contents of other directories in the list box.

The Directory Contents list box contains

  • A list of the available files in the current directory (if any), filtered by the current mask (See Marker file endings and Masks below).
  • A list of the subdirectories of the current directory (if any) (shown with a slash following; e.g., EBA_GRAV/ in the illustration), and
  • The notation ../ representing the parent directory of the currently displayed directory (unless the current directory is the root directory).

The Path text box shows the path of the currently displayed directory either relative to the working directory or as a full path. If you select a file or dataset, INTREPID immediately includes its name in the Path text box.

Changing the currently displayed directory

Under Linux, to change the currently displayed directory to its parent directory or one of its subdirectories, double click the parent directory symbol (../) or the name of the subdirectory required in the list box. (You can also click and press enter.)

Under Windows, use normal directory navigation methods.

INTREPID displays the contents of the new directory in the list box.

Marker file endings and Masks

INTREPID uses marker files with special endings (e.g., ..LINE, ..PNT, ..POLY, .ers) to identify datasets, fields or other files.

Under Linux, INTREPID usually hides the endings of marker files, producing a simple list of names of fields or datasets.

Under Windows INTREPID displays the marker file endings.

When you are specifying input or output INTREPID uses a wildcard mask to display only file types relevant to the operation. For example, if you are seeking a vector dataset, INTREPID can use the mask *..DIR. For a field of a line dataset, it can use the mask ..LINE.

  • Since INTREPID can process data in other formats, it includes the file extensions of these formats in the mask. For example, a general vector dataset mask would be *..DIR, *.gdb, *.jdbc, *.shp
  • Most INTREPID tools now display a field chooser dialog box for selecting fields rather than an Open dialog box with a mask.
  • INTREPID versions before 3.7 used a ..GRID extension to identify a grid dataset instead of .ers.

See “File Masks” in INTREPID database, file and data structures (R05) for a list of masks.

Vector dataset and field names vs directories (Linux)

When you are using INTREPID under Linux some input/output dialog boxes have a single list box. This box shows some or all of the contents of a directory depending on the mask that is operating. This contains both the names of the target files or datasets and the names of subdirectories (and ../ representing the parent directory).

If you are specifying an input or output dataset the directory you are viewing contains a vector dataset, you may see two entries for the dataset in the list box.

Navigation for INTREPID has been simplified in Linux, for any issues with navigation contact INTREPID support.

Dataset and field names vs directories (Windows)

A file ending in ..DIR and a directory with the same name (but no ..DIR) indicates a INTREPID format vector dataset in a load/save dialog box. Example:

intbvecw.png

If you are selecting the dataset as a whole, select the ..DIR file.

If you are selecting a field of the dataset, (in our illustration, a field of dataset ebagoola_F), open the directory to find the fields of the dataset INTREPID tools now use a field selector dialog box for loading fields.

intbself.png

Load/Open or Save button

When you have selected the directory and file name required, choose Load/Open or Save. INTREPID will note the file’s name for use with the current application, then close the file selection dialog box.

Depending on the application, INTREPID may also

  • Open the file and examine its contents (if it is an input file),
  • Display some data from the file (if it is an input file),
  • Save the files (if it is an output file).
  • Automatically display the next required file selection dialog box (if you are specifying vector data and need to specify separate X, Y, Z and other component files).

Pixellation and zoomed-in grids

If you are viewing a grid dataset and zoom in the view so that only a few cells are visible, INTREPID can still display the grid with continuous colour or grey shades rather than showing the whole of each individual cell with its corresponding colour or shade.

Continuous colour or grey scale display will provide you with a superior grid for judging trends in the data. If the whole of each cell has its correct colour or shade, the grid will have a ’pixelated’ (tiled) effect, but will portray more precisely the data that you have.

INTREPID normally creates continuous colour and shade display using third order Newton approximation.

If you prefer, INTREPID can use bilinear interpolation. This is an early method which third order Newton approximation has replaced. We recommend the default third order Newton approximation for normal use.

If you wish to disable continuous colour display and show the whole of each cell with its corresponding colour or shade, INTREPID can use the nearest cell centroid method for determining the colour of a pixel on the screen.

To use third order Newton approximation for continuous colour or grey scale display

Ensure that the system parameters INTREPID_BILINEAR and INTREPID_NEAREST have no value (= NULL).

To use bilinear interpolation for continuous colour or grey scale display

Assign a value to the system parameter INTREPID_BILINEAR.

To use the nearest cell centroid method for determining pixel colour or shade

Assign a value to the system parameter INTREPID_NEAREST.

See INTREPID system parameters and install.cfg (R07) for further information.

Summary of INTREPID tools

See “Launching INTREPID tools” in INTREPID Project Manager (T02) for lists of INTREPID tools.