↑ Top
Table of Contents

3D Explore (T61)

Main sections of manual

The manual has the following main sections:

Introduction

Parent topic: 3D Explore (T61)

3D Explore is a tool for integrated visualising and editing of 2D and 3D datasets. It features linked dataset Table windows, Plot windows, and Map windows. Changing the focus or selection in one view is instantly reflected in all other open views. It supports of INTREPID’s data types. For a full list of supported data formats see 3D Explorer data formats.

See Getting Started with 3D Explore (G23) for an introductory level guided tour of INTREPID 3D Explore.

3dxp0010.png

Icons used in this manual

In the sidebar of the PDF version of this manual you will see some icons associated with sections of text. These indicate the aspects of 3D Explore to which the text applies. The following table has an explanation of the icons

Icon

Indicates

ico_table64.png

Relevant to table window operations

ico_profile64.png

Relevant to profile window operations

ico_map64.png

Relevant to map window operations

Use the gear icon to show and hide the Inspector (See Inspectors overview)

iconline00145.png

Relevant to line datasets

icongrid00147.png

Relevant to grid datasets

Terminology used in this manual

Disambiguation—’vector’

In this documentation we use the word ‘vector’ in two contexts:

A vector dataset is a dataset containing information about points in a physical space. The points may or may not be arranged in lines that reflect the survey method. Associated with each point is a set of values or fields. We could describe the collection of field values for an individual point as a multidimensional vector. For this reason we refer to such a dataset as a ‘vector’ dataset.

For convenience, INTREPID can group together a set of point values in the form of an array and store them together under one field name. We call this a multiband field. Some multiband fields contain 2– or 3–dimensional vector data and so the term ‘vector’ may become a source of confusion.

If we refer to a multiband field that describes a 2 or 3 dimensional vector, we may call it a vector field when talking about storing the data. In all other cases we’ll use the term multiband field.

Overview of program features

Parent topic: 3D Explore (T61)

You can do the following visualisation activities using 3D Explore:

  • View datasets as:
  • Maps
  • Tables
  • Overlay several datasets in a map display
  • Configure the orientation and magnification of a map display (for example, zoom, pan, rotate) according to your requirements
  • In a table display:
  • Configure the appearance of the data
  • Conveniently locate and examine specific data
  • Edit the data, including bulk updates
  • Create graph (plot) views from data in a Table window and view them together in a window
  • Select a polygon in a map display by clicking its corner points, and:
  • Show it as a highlight
  • Set the points inside or outside the polygon to Null.
  • Select a subset of data and see the same subset highlighted in other displays of the dataset (for example, in a map, a table and a graph (plot))
  • Export an image of the current Map window
  • Save and load workspaces with their current configuration (.3dexplore files), so that you can resume work or quickly display data at a later time
  • Load and display data and use batch mode with .task files.

3D Explorer data formats

Parent topic: 3D Explore (T61)

3D Explore supports all the data format types of INTREPID including tensors, SEGY, ERMapper grids, GoCAD voxets and Tsurfs as well as Geosoft GDB datasets and GRD grids. For further information about INTREPID supported file formats see INTREPID database, file and data structures (R05).

Survey types

Types of survey data you can view:

  • Magnetics
  • Magnetotellurics (MT)

For a dataset description, see “Magnetotellurics (MT)” in INTREPID database, file and data structures (R05)

  • Airborne electromagnetics (AEM)
  • Radiometrics
  • Gravity
  • Seismic

File formats supported by 3D Explore

  • point, line and gridded datasets
  • 3D grids,
  • Triangulated surfaces such as .tsurf and .vtk
  • Voxets, which is a 3D regular Grid Object. It is defined by an origin, three axis vectors, and the number of Nodes along the axes. Often used to store seismic information.

Exotic field data supported

The *.edi, just select it in the Project Manager and run 3D Explore from the main menu.

The display for AEM data in geomodeller wizard should be possible

The standard stuff:

  • radiometrics 256 channel,
  • SEGY,
  • tensor,
  • vectors,
  • any arrays (AEM data)

The MT data types, There is an intrepid point data base with MT data embedded

Complex 2D tensors.

Data formats

Data formats you can view:

  • Scalar data in line, point or grid datasets (see INTREPID database, file and data structures (R05))
  • Arrays in line or point datasets
  • 256 channel radiometrics data
  • Vector data in line, point and grid datasets
  • Tensors in line, point or grid datasets:
  • 3D tensors
  • Complex 2D tensors
  • 3D grid data in Voxets
  • Seismic data in SEG-Y format
  • Surface data in TSurf format
  • (Available in future versions of 3D Explore)Irregular grids .igmesh

Note about .edi format

Open .edi files from INTREPID Project Explorer. 3D Explore identifies the dataset type and displays it appropriately

Advanced examples in this manual

The following table is a guide to advanced 3D Explore-compatible data formats, examples used and links to information about specific formats.

Type

Ext

Example dataset used in this manual

Notes

3D Tensor vector (line) dataset

sample_data/cookbooks/tensors/BrokenHill_Falcon/BH_1_DB

3D

Tensor grid dataset

sample_data/cookbooks/tensors/BrokenHill_Falcon/BH_2_GRIDS/BH_TC_T_lev_25m.ers

3D

Vector

sample_data/cookbooks/vectors/Databases/Sanders/s1/G_acc

Vector Magnetotellurics (MT)

sample_data/datasets/olympic_dam

sample_data/datasets/s110_edi2.edi

http://www.ga.gov.au/scientific-topics/disciplines/geophysics/magnetotellurics

https://en.wikipedia.org/wiki/Magnetotellurics

ico-tensor-2.png tensor 2 icon example

SEG-Y

.sgy

sample_data/examples/seismic/admella_B097B_121.sgy

https://en.wikipedia.org/wiki/SEG-Y

256 channel radiometrics data

sample_data/cookbooks/radiometrics/cookrad_new

Airborne electromagnetics (AEM)

Tutorial_E/SPECTREM/Bryah_Basin_Database/Bryah_Basin_Exponential_Processed_DeGrussa_Detailed.gdb

Geomodeller Tutorial E

DXF

.dxf

examples/mining/Middle_Ore-BHPEM.dxf

AutoCAD drawing exchange format.

https://en.wikipedia.org/wiki/AutoCAD_DXF

Voxets

.vo

sample_data/datasets/3D_data/final.vo

GoCAD

https://scholar.harvard.edu/files/plesch/files/gocadinahurry.pdf page 84

Tsurf

.ts

.ts

GoCAD

Tutorial A Geomodeller

example: TutorialA4_Granite.ts

Table view has two types

  • standard vector dataset with row group x y z
  • mesh with facet group and facet , nodes 1-3, formation, colour

https://scholar.harvard.edu/files/plesch/files/gocadinahurry.pdf page 100

IgMesh

.igmesh

available in the future

Irregular grid

https://trove.nla.gov.au/work/217095859?q&versionId=238199893

https://www.indigorenderer.com/indigo-technical-reference/indigo-mesh-file-format-specification

Example datasets used for other discussions in the manual

Type

Ext

Example dataset used in this manual

Notes

Histogram

sample_data/guided_tours/intrepid_datasets/L_mlev_grid

sample_data/guided_tours/intrepid_datasets/Albury/rawmag

Plot window showing two fields

sample_data/cookbooks/radiometrics/R_DB/cookrad_new/spectrum and spectrum_nasvd

Two way time depth frequency plots

sample_data/examples/seismic/admella_B097B_121.sgy

3D Explorer workflow overview

Parent topic: 3D Explore (T61)

For basic use of 3D Explore you generally follow these steps

  1. When you start 3D Explore the Workspace window appears
  2. You open:
    • Datasets OR
    • Previously saved 3D Explore workspace (.3dexplore) files) OR
    • 3D Explore .task files

    Tip: .3dexplore files can have their file extension renamed to .task and they will function the same.

  3. 3D Explore lists the open datasets in the Workspace window and opens them in other windows for data display
    • Vector datasets first open in Table windows. You can also show them in Map windows.
    • Grid datasets first open in Map windows. You can also show them in Table windows.
  4. From a Table window displaying any dataset you can show a plot of:
  • (Vector dataset) Any column (values of a field) or set of columns (non-scalar fields)
  • (Grid dataset) Any row or column

In the Workspace window 3D Explore lists every data view that you create.

You can:

  • Format Profile and Map windows to show data according to your requirements and
  • Export images of the window contents

The flowchart below is an outline of the basic 3D Explore data viewing workflow, showing:

  • The original display format when you open different types of dataset and
  • Other display possibilities after you view the original display

About the 3D Explorer user interface

Parent topic: 3D Explore (T61)

3D Explore stores the results of your visualisation and editing session in a Workspace—a list of datasets and the current settings for displaying them. Workspaces are stored in files with the extension.3dexplore.

The 3D Explore workspace user interface consists of:

  • The Workspace window
  • Data view windows—Table, Map and Plot
  • Data view window menus, Inspectors and shortcut menus

In this section:

Shortcut menus are specific to the type of window. For information, see the following topics outside this section:

The Workspace window—overview

Parent topic: About the 3D Explorer user interface

The Workspace window lists the currently open datasets and views.

3dxp_proj_3_items.png

For more information, see The Workspace window

Data view windows—overview

Parent topic: About the 3D Explorer user interface

There are three types of data view windows:

Table window

There is a Table window for every dataset listed in the Datasets section. A Table window contains all data values in the dataset

3dxp0250.png

For more details, see 3D Explore - Table window layout and operations (T61a).

Map window

There is a Map window for every dataset or dataset field listed in the Workspace window under Maps). In the Map window is a spatial representation of the dataset viewed from a chosen direction.

3dxp0090.png

For more details, see 3D Explore - Map window operations (T61c).

Plot window

There is a Plot window for every dataset or field listed in the Plots section. It represents an aspect of some or all of the data as a graph.

3dxp0290.png

For more details, see 3D Explore - Plot window operations (T61b).

Menu bar overview

Parent topic: About the 3D Explorer user interface

The main menu bar appears at the top of all four types of 3D Explore window. 3D Explore enables or disables menu items according to the type of window and the current context. This section is an overview of all menu operations.

File menu

3dxp_mfile.png

See Managing workspaces and their contents

Edit menu

3dxp-menu-edit.png3dxp-menu-edit-gr.png

Undo and Redo—Undo or redo the previous action. Note that when you close 3D Explore, this record of actions in the session is deleted

Null selected data—If you have currently selected data in a Table or Map window, use this option to change the data values to Null.

Find— See Finding data (Search)

Add Column(table window only) See “Table window editing” in 3D Explore - Table window layout and operations (T61a)

Add Column by Formula(table window only) See “Table window editing” in 3D Explore - Table window layout and operations (T61a)

Plot menu

3dxp0270.png

You can select data and use the options in the Plot menu to display it graphically in a Plot window. For full details about Plot windows, see 3D Explore - Plot window operations (T61b). Plot windows can display the following:

Profile plot – A profile graph of the values selected. See “Plot window—Profile plots” in 3D Explore - Plot window operations (T61b)

Spectral plot – See “Plot window—Spectral plots” in 3D Explore - Plot window operations (T61b)

Two Way Time Depth Frequency plot – ***. See “Plot window—Two Way Time Depth Frequency plots” in 3D Explore - Plot window operations (T61b)

Histogram plot – A histogram of the values of the data selected. See “Plot window—Histograms” in 3D Explore - Plot window operations (T61b)

Map menu

3dxp0250.png

The Map menu has the following options:

Create Map In a Table window choose Create Map to display the data from that window in a new Map window

Reset view (Map window only) Display the default view of the window contents See “Reset view” in 3D Explore - Map window operations (T61c).

Print (Map window only) Export the current window contents. See “Print” in 3D Explore - Map window operations (T61c).

Mode menu and buttons

3dxp-menu-mode-pro.png3dxp-buttons-mode-prof.png
3dxp-buttons-mode-map.png3dxp-menu-mode-map.png

There is a Mode menu in both the Map and Profile windows. In both cases it duplicates the mouse mode buttons in the window. Use the options to select the required behaviour of your mouse.

For more details, see:

Window menu

3dxp-menu-window.png

The Window menu has the following options:

Minimise – Minimise the current window

Next Group, Previous Group (Table and Plot window only) – Select (Table window) and (Plot window) display the next or previous group See ***

Next Row in Database, Previous Row in Database (Table and Plot window only) – Select (Table window) and (Plot window) display the next or previous row in the table. See ***

Show inspector – Show the Inspector options panel for the window. This option has the same effect as choosing the ‘gear’ icon . See ***

Arrange – Bring all open windows to the top of main screen (they may overlay each other)

Bring all to front – Bring all currently open windows to the front

Currently open windows list – Select a window to bring it to the front

Inspectors overview

Parent topic: About the 3D Explorer user interface

Each data view window type has an extension, the Inspector, which enables you to configure the contents and appearance of the window.

To show or hide the Inspector, choose the ‘gear’ icon or the menu item Window > Show Inspector or use the keystroke ctrl+alt+i.

This section has an overview of the Inspectors, with links to their detailed descriptions

Table window Inspector overview

The Table window Inspector has controls for formatting the data in the table and in the selected field.

3dxp-vect-table-inspector.png

For more details see “Table window Inspector” in 3D Explore - Table window layout and operations (T61a).

Plot window Inspector overview

The Plot window Inspector has controls for:

  • The title and legends
  • The grouping of plots
  • Fields and parameters for both individual files and within groups
3dxpspec.png

For more details, see “The Plot window Inspector” in 3D Explore - Plot window operations (T61b).

Map window Inspector overview

The Map window Inspector has control of:

  • Configure Presentation
  • Title properties
  • Legend and Scalebar properties
  • Line Number, Point Label properties
  • Word Axis (ENU END .etc), North arrow and Cube Axis properties
  • The grouping of map components:
  • Grids
  • Vector dataset fields

3dxp-map-overlay-example.png

For more information see “Map window Inspector controls” in 3D Explore - Map window operations (T61c).

Datasets with multiband fields

For more information please contact our technical support service.

Disambiguation—’vector’

In this documentation we use the word ‘vector’ in two contexts:

A vector dataset is a dataset containing information about points in a physical space. The points may or may not be arranged in lines that reflect the survey method. Associated with each point is a set of values or fields. We could describe the collection of field values for an individual point as a multidimensional vector. For this reason we refer to such a dataset as a ‘vector’ dataset.

For convenience, INTREPID can group together a set of point values in the form of an array and store them together under one field name. We call this a multiband field. Some multiband fields contain 2– or 3–dimensional vector data and so the term ‘vector’ may become a source of confusion.

If we refer to a multiband field that describes a 2 or 3 dimensional vector, we may call it a vector field when talking about storing the data. In all other cases we’ll use the term multiband field.

Using 3D Explorer—common steps

Parent topic: 3D Explore (T61)

If you are editing, note that you can only undo changes during the current 3D Explore session. When you exit from 3D Explore, INTREPID deletes its track of the changes that you made in that session.

Steps for interactive use
  1. Use one of these methods to start the tool and open the required datasets:
    • From the Windows Start menu in the section for your current version of INTREPID, choose Intrepid 3D Explorer
    3dxp0030.png
    • In Project Manager:
    • (If required) Select the required:

    —vector or grid dataset or

    3D Explore workspace (.3dexplore) file or

    —task (.task) file

    • From the Editing or Display menu, choose 3D Explore,
    3dxp0050.png3dxp0070.png
    3dxp0110.png
    • Use the command 3dexplore.exe.

    INTREPID displays 3D Explore windows with content according to any input file you have selected.

  2. If you have an existing 3D Explore workspace (.3dexplore) or task (.task) file that you require and is not already open,
  3. If all of the specifications are correct in this file, go to step 5. If you are starting a new project or want to modify any settings, carry out the following steps as required.

  4. Create and save a new 3D Explore workspace. Choose File > New workspace. (See Managing workspaces and their contents for detailed instructions.)
  5. Open the grid and vector datasets that you want to view or process and then save the Workspace. (See Managing workspaces and their contents for detailed instructions.)
  6. INTREPID displays the Workspace window with the datasets listed in it.

    3dxp_proj_3_items.png
  7. Perform the visualisation, editing and other operations that you require. See the sections later in this manual for instructions.
  8. If you want to record the dataset views from this session then save the Workspace file. (See Managing workspaces and their contents for detailed instructions.)
  9. To exit from 3D Explore, close the Workspace window

You can view Help information by choosing options from the Help menu (See Help).

Managing workspaces and their contents

Parent topic: 3D Explore (T61)

In this section:

The Workspace window

Parent topic: Managing workspaces and their contents

The Workspace window:

3dxp_proj_5_items.png
  • Contains a list of the various display windows that you have opened
  • Has menu controls for
  • Importing datasets and
  • Creating and displaying data display windows

If you open a dataset, it first appears in its own window. You can add datasets and fields to display windows.

You can display tables (called ‘Datasets’ in the Workspace window), Maps and graphs (‘Plots’) of data from both vector and grid datasets. A map or table may have some different characteristics corresponding to the dataset type that it is displaying.

Example

3dxp_proj_5_items.png

In the example of a Workspace window above, the user has displayed:

  • Tables (‘Datasets’) of:
  • The vector dataset (ebagoola_S)
  • Maps of:
  • The grid dataset (mlevel_grid)
  • The smooth_mag field of the vector dataset ebagoola_S
  • A Plot of the smooth_mag field of the vector dataset ebagoola_S

Managing workspaces, adding and removing datasets

Parent topic: Managing workspaces and their contents

To use 3D Explore to view or edit datasets, you need to:

  1. Create or open a 3D Explore workspace
  2. Add datasets to or remove them from the workspace as required
  3. When finished work, save:
  • The workspace
  • Any datasets that you have edited

The File menu has controls for creating, populating, saving and closing workspaces

3dxp_mfile.png

In each case, except for creating a new workspace, INTREPID displays an Open or Save As dialog box. Use the directory and file selector to locate the file you require. (See “Specifying input and output files” in Introduction to INTREPID (R02) for information about specifying files).

New Workspace Use this option to create a new workspace. INTREPID opens it in a 3D Explore workspace window. You can have multiple workspace windows open during a 3D Explore session

Open Workspace Use this option to open an existing workspace. INTREPID opens it in a 3D Explore workspace window, listing datasets and restoring the windows from your previous session

Open datasets Use this option to open a dataset in 3D Explore:

  • Listing it in the workspace window and
  • Displaying it in its own window.

By default:

Save <dataset_name> This option is available in a window displaying a dataset that you have edited. Use it to save the dataset.

Save Workspace Use this option to save the currently active workspace, with the current display settings for the datasets it describes.

Close <workspace_name> Use this option to close the currently selected workspace. Before closing the workspace, INTREPID prompts you to save any unsaved changes in:

  • Window display settings
  • Edited datasets

Open ‘3DEXplore.----.log’ Select this option to display the log of actions performed in the current 3DExplorer session. For more information, see “What are Log files?” in INTREPID task, HISTORY, report and log files (R06).

Recent Files Select this option for a list of recently viewed datasets. Select any that you want to add to the current workspace.

Recent Workspaces Select this option for a list of recently used workspaces. Select any that you want to open.

Opening a Table window for a grid dataset

Parent topic: Managing workspaces and their contents

When you add a grid dataset to a 3D Explore workspace, 3D Explore normally opens it in a Map window. To open it in a Table view

To open a table window for a grid dataset:
  1. Ensure that you have opened the grid dataset and it is listed in the Workspace.
  2. Select the grid dataset in the workspace
  3. Right-click the grid and choose Open Table view for dataset_name’.
3dxp-open-grid-table.png

Removing Tables (‘Datasets’), Plots and Maps from a workspace

Parent topic: Managing workspaces and their contents

To remove a Table (‘Dataset’), Plot or Map from a workspace:

  1. In the 3D Explore window, select the item you want to remove
  2. Right-click <item name> > Close will remove that view from the workspace.
3dxpdlws.png

Note that 3D Explore only deletes the selected view of the dataset. Any other views of that dataset will remain.

Synchronising multiple windows

Parent topic: 3D Explore (T61)

If you select part of a dataset in one 3D Explore window, 3D Explore shows the selection in all open windows that contain that data.

Similarly, if you update data in the table window, 3D Explore updates all windows that show that data with the new values.

Grid dataset examples

Note: When you first view a Grid dataset in the Profile window, it may appear as thick horizontal line. To view the profile, follow these steps:

  1. Display the Inspector
  2. For each Group displaying a flat line, change Range to Independent

Grid dataset example 1

This example shows how 3D Explore shows selected data in the Map window and Table window. The user could have selected this data either by

  • Digitising in the Map window or
  • Clicking, dragging and ctrl+clicking data in the Table window.
3dxp-selection-map.png3dxp-selection-table.png

Illustrated above is a data selection in a Map view and Table view

Grid dataset example 2

This example shows the display resulting from selecting a single data point in the Table or the Map window. The selected Group and Row have a yellow background in the Table window and shown as cross hairs in the Map window. The Profile window has a profile graph for the current Group (13) showing the data values for all Rows.

3dxp-ll-grid-prof-sel-table.png3dxp-ll-grid-prof-sel-map.png
3dxp-ll-grid-prof-sel-plot.png

Group 13 and Row 73 Selected in the Table window, displayed as cross-hairs in the Map window, and cross-hairs in the Profile window.

Grid dataset example 3

This example shows the display resulting from selecting a block of values within in a Group of a Grid dataset. You can do this using any of the following methods

  • Selecting the required cells in a Group in the Table window
  • Dragging the mouse pointer horizontally across the required range of Rows in the Profile window
  • Choosing Select mode in the Map window and selecting the required Rows of cells

The selected cells appear as a grey block in the Map window. The Profile window shows the Rows of the selected cells as a rectangular blue region.

3dxp-ll-grid-group-sel-table.png

Selected Rows 67-70 of Group 11 in Table window, cursor is at Row 80.

3dxp-ll-grid-group-sel-plot.png3dxp-ll-grid-group-sel-map.png

Profile plot of Group 11 in Profile window, Rows 67-80 are highlighted, In the Map window, cross-hairs show Row 80 and Group 11, Selected values within Rows 67-80 of Group 11 appear as the highlighting rectangle.

Grid dataset example 4

This example shows a collection of cells selected in the Table window by:

  • Clicking and dragging OR clicking and shift+clicking to select the rectangle and then
  • ctrl+clicking the single cells

The same selection appears in grey in the Map window.

It is not possible to:

  • Digitise a selection of separate cells in the Map window
  • Select more than one range of rows in the Profile window

In the Profile window, which shows the profile of the currently selected Group 8, has blue columns at the Rows where there are selected cells from the current Group (Rows 68, 71 and 73–76). If you select a different Group using the controls in the Profile window or Table window, the blue columns will change, appearing for the Rows where there are selected cells for the current Group.

Tip: You may need to choose Reset View to update the display.

3dxp-ll-grid-ctrl-click-table.png3dxp-ll-grid-ctrl-click-map.png

Table window displays the block of data, with additional selected cell, these were obtained by using ctrl+click. Data was selected in Rows 68, 71, and 73-76. In the Map window, the data appears in highlighting rectangles/squares.

3dxp-ll-grid-ctrl-click-plot.png

Profile graph of Group 8, showing selected data present in Rows 68, 71 and 73-76.

Line dataset examples

Line dataset example 1

This example shows the display of a selected block of data point values from a single field of a line dataset.

You can do this using any of the following methods

  • Selecting the required block of values in the field in the Table window
  • Dragging the mouse pointer horizontally across the required range of data points in the Profile window
  • Choosing Select mode in the Map window and selecting the required range of data points along a line by dragging the mouse along the required section of the line

If you select the value using the Table or Map window and you have the Profile window open, 3D Explore automatically displays the profile of the selected line.

3dxp-ll-sel-table.png3dxp-ll-sel-plot.png
3dxp-ll-sel-map.png3dxp-ll-sel-map-zoom.png
Data selected in the Table view is displayed and selected in the Profile view and Map view.

Finding data (Search)

Parent topic: 3D Explore (T61)

In 3D Explore you can search the whole workspace or a single dataset for text or values. The scope of a search can include datasets open in the current workspace—all datesets or a single dataset that you select You can start a search in a workspace from any of its windows.

To use search
  1. In any 3D Explore window, choose Edit > Find . The Find dialog box appears.
  2. 3dxp-find.png3dxp_sel_cols.png
  3. In the Scope area, select the scope of your search:
    • Workspace—All datasets in the workspace
    • Dataset—A dataset in the workspace
  4. (If you selected Dataset):
    1. Select the required dataset from the Dataset drop-down list
    2. In the Columns field, type the column names, separated by commas OR
      Click Choose... and select the required columns from the Select columns dialog box. You can:
      • Choose Select All
      • Choose De-select All
      • Use the mouse to select the columns required. To select a range of columns, click the first required columns and then shift+click the last required column. To select individual columns, click the first columns and ctrl+click the other required columns
    3. Choose OK
  5. In the Condition area select the type of data you are searching:
    • Text
    • Nulls
    • Range (numeric values)
  6. (If you are searching for text):
    1. Enter
    2. Check Case-Sensitive, Regular Expression and Whole Word as required
  7. (If you are searching for a numeric range):
    • Enter values for the Upper Bound and Lower Bound
    • To include Bound values, check the corresponding Inclusive check box
    • To exclude values between the Bounds and locate values outside the Bounds, check Exclude Values in Range.
  8. To select (highlight) search results, check Select Found Terms
  9. Select Prev or Next to move through your search results. 3D Explore changes focus to each matching value in Table and Profile views as you move through the dataset
  10. To end the Find operation, choose Close.

Keyboard shortcuts

Parent topic: 3D Explore (T61)

3D Explore has the following keyboard shortcuts

Keystroke

Function

Replaces menu item

ctrl+alt+n

Create a new workspace

File > New Workspace

ctrl+alt+o

Open an existing workspace

File > Open Workspace

ctrl+o

Open a dataset

File > Open Datasets

ctrl+s

Save changes to the current dataset

File > Save dataset_name

ctrl+alt+s

Save the current workspace

File > Save Workspace

ctrl+z

Undo the last action

Edit > Undo

ctrl+y

Redo the last action

Edit > Redo

delete

Change the value of the selected data to Null

Edit > Null Selected Data

ctrl+alt+p

Create a Profile plot from the selected data

Plot > Create Profile Plot

ctrl+alt+m

Create a map from the current dataset

Map > Create Map

s

Mouse mode—Select
(use lower case)

Mode > Select

d

Mouse mode—Digitise
(use lower case)

Mode > Digitise

p

Mouse mode—Pan
(use lower case)

Mode > Pan

z

Mouse mode—Zoom
(use lower case)

Mode > Zoom

r

Mouse mode—Rotate
(use lower case)

Mode > Rotate

ctrl+m

Minimise the current window

Window > Minimise

ctrl+]

View the next group in the dataset (for example, next line in a line dataset)

Window > Next Group

ctrl+[

View the previous group in the dataset (for example, previous line in a line dataset)

Window > Previous Group

ctrl+shift+]

View the next row in the dataset table (for example, next data point in a line or grid ‘dataset)

Window > Next Row in Database

ctrl+shift+[

View the previous row in the dataset table (for example, previous data point in a line or grid (dataset)

Window > Previous Row in Database

ctrl+alt+i

Show or hide the Inspector

Window > Show inspector

Help

Parent topic: 3D Explore (T61)

To view this manual, choose Help > 3D Explorer Help.

You can find Help for this tool:

  • In this manual
  • In tool tips that the tool displays for most screen elements. Point to an element and the relevant tool tip appears.

See the example below.

3dxp_mouse_tips.png

Exit

Parent topic: 3D Explore (T61)

To exit from 3D Explore:

  1. As required, in each Workspace window, save the Workspace (see Managing workspaces and their contents)
  2. Close all Workspace windows. In each case, choose Save or Don’t Save in the Confirmation Requested dialog box for the Workspaces that you did not save in the previous step.
3dxp-confirm-exit.png

Displaying settings and using task specification files

This section has information about .task file operations with this tool:

Saving settings for later use—.3dexplore and .task files

To view current settings, you can, of course, examine the settings in the 3D Explore windows. To store settings after your 3D Explore session or to reuse settings, use Workspace (.3dexplore) or task (.task) files. These two files types are functionally the same as of INTREPID 6.0.2.

Workspace (.3dexplore) files

You can store the current settings in a workspace .3dexplore file. This file contains a list of the datasets, windows and configurations current at the time you saved the file. When you reload the file. You can reload the file interactively in 3D Explore and view the same data. For instructions, see Managing workspaces, adding and removing datasets.

Task (.task) files

You can also load a 3D Explore configuration using a task specification (.task) file.

If you want to create your own 3D Explore .task file in the current version of INTREPID you can create one by opening a Plot, Map or Table window and selecting File > Save Map/Plot/Table View as. Alternatively, you can save the entire workspace as a .3dexplore file and change the file extension to .task.

Once you have created the .task file you can open a 3D Explore display using a typed command and include the operation in a batch file.

For the 3D Explore .task file syntax see Location of protobuf definitions.

For a 3D Explore .task file example see Task specification file example

Location of protobuf definitions

Where install_path is the path of your INTREPID installation, the folder for the protobuf definitions is install_path\extras\protobufs.

For example, if INTREPID is installed in
C:\Intrepid\Intrepid6.0,
then you can find the sample data at
C:\Intrepid\Intrepid6.0\extras\protobufs

The protobuf syntax for 3D Explore .task files is in the file intrepid_3dexplore.proto.

Opening.3dexplore and .task files

From the 3D Explore workspace, select File > Open TaskFile or ctrl+t to open a .task file, or File > Open Workspace or ctrl+alt+o to open a .3dexplore file.

In a Plot/Table/Map window selecting File > Open TaskFile will open the task file.

Running the tool in batch mode

You can run this tool in batch mode with a .task file.

To use a task specification file for a batch mode 3D Explore task

Type the command 3dexplore.exe with the switch -batch followed by the name of the task specification file.

For example, if you had a task specification file called surv329.task in the current directory, you would use the command:

3dexplore.exe –batch surv329.task

Task specification file example

Here is an example of a 3D Explore task specification file.

# Example of creating a map view with two datasets, a tensor grid and DTM. # Note, there are many tensor grid enhacements, we choose 3 complimentary enhancements, known as second balanced gradients # the richness of the measured tensor gradients prove elusive to show in one enhacement # as with other geophysics signals, a Ternary plot, using Red/Green/Blue and sun angle shading # offers the best possibility of combining the relationships between the gradients # we apply Red to the Z components, as this will be dominant for gravity. # in this case, we have Nevada tectonic rift and transfer faults # NB, the definition of the Horst blocks, and the Green indicating NS thrust # and the Blue indicating EW thrust # the degree of uplift pressure is also indicated by the RED, especially on the # points in the faults that are most stressed. Intrepid3DExplore { mapView { titleText: “Montezuma tensor grid, Second Balanced Gradient components as a Ternary draped on DTM” datasetGroupConfig { Scale: 5; datasetConfig { filename: “${examples}/datasets/TensorGradients/zuma_tensor.ers”; signalQuery: TENSOR_SecondBalancedGradientZ elevationFile: “${examples}/datasets/TensorGradients/mv_dem.grd” ; visible: true interpolate: true useZAxis: true; colourMode: Rgb_Ternary_SunAngle lutConfig { name: “red” } } datasetConfig { filename: “${examples}/datasets/TensorGradients/zuma_tensor.ers”; signalQuery: TENSOR_SecondBalancedGradientY elevationFile:”${examples}/datasets/TensorGradients/mv_dem.grd” ; visible: false interpolate: true useZAxis: true; colourMode: Rgb_Ternary_SunAngle lutConfig { name: “green” userDataBounds { minimum: 0.26225294046661557 maximum: 18.450906571137665 } visualBounds { minimum: 0.26225294046661557 maximum: 18.450906571137665 } type: HistoLut } } datasetConfig { filename: “${examples}/datasets/TensorGradients/zuma_tensor.ers”; signalQuery: TENSOR_SecondBalancedGradientX elevationFile: “${examples}/datasets/TensorGradients/mv_dem.grd” ; visible: false interpolate: true useZAxis: true; colourMode: Rgb_Ternary_SunAngle lutConfig { name: “blue” userDataBounds { minimum: 0.26225294046661557 maximum: 18.450906571137665 } visualBounds { minimum: 0.26225294046661557 maximum: 18.450906571137665 } type: HistoLut } } } } }

You can find more examples in the INTREPID sample data folders.

Location of INTREPID sample data

Where install_path is the path of your INTREPID installation, the sample data folder is install_path\sample_data.

For example, if INTREPID is installed in
C:\Intrepid\Intrepid6.0,
then you can find the sample data at
C:\Intrepid\Intrepid6.0\sample_data

For a description of INTREPID datasets, see Introduction to the INTREPID database (G20). For more detail, see INTREPID database, file and data structures (R05).

3D Explore .task file examples are in the folder examples/Tasks/Visual/3DExplore.